COMPORTEMENT JOG BIZARRE

Que ce soit l'impression, où l'imprimante, posez ici vos questions concernant les réglages. Évidemment, pour pouvoir vous répondre, ce sera toujours une bonne idée d'indiquer quels sont vos réglages actuels, et éventuellement une photo montrant le problème (si problème il y a!)
Avatar du membre
samsab
Apprenti
Messages : 30
Enregistré le : 24 sept. 2021, 12:51
A remercié : 1 fois
A été remercié : 1 fois

COMPORTEMENT JOG BIZARRE

Message non lu par samsab » 19 févr. 2022, 17:16

bonjour à tous
TOPSCNC + GRBL 1.1H + ARDUINO UNO
je découvre un comportement étrange quelque soit le logiciel utilisé CNJS ou UGS ou LASER GRBL
le jog à l'écran fonctionne correctement sur tous les axes utilisés seuls (que j’appelle NORD, SUD EST OUEST) , sur presque tous les axes combinés que j'appelle nord ouest, sud ouest, sud est MAIS aucune déplacement sur NORD EST. qu'est ce qui peut expliquer ce non fonctionnement trés particulier
l'axe z fonctionne normalement.
A vous lire
CNC TOPSCNC + NEMA 23 + ARDUINO GRBL 1.1 sans cncshield, pontage direct de y1 et y2, plutôt UGS en ce moment
Avatar du membre
DranerB
Administrateur
Messages : 3311
Enregistré le : 31 janv. 2019, 11:56
Localisation : Bourbon-Lancy, France
A remercié : 160 fois
A été remercié : 275 fois
Contact :

Re: COMPORTEMENT JOG BIZARRE

Message non lu par DranerB » 19 févr. 2022, 23:30

samsab a écrit : 19 févr. 2022, 17:16 bonjour à tous
TOPSCNC + GRBL 1.1H + ARDUINO UNO
je découvre un comportement étrange quelque soit le logiciel utilisé CNJS ou UGS ou LASER GRBL
le jog à l'écran fonctionne correctement sur tous les axes utilisés seuls (que j’appelle NORD, SUD EST OUEST) , sur presque tous les axes combinés que j'appelle nord ouest, sud ouest, sud est MAIS aucune déplacement sur NORD EST. qu'est ce qui peut expliquer ce non fonctionnement trés particulier
l'axe z fonctionne normalement.
A vous lire
Les axes ont des noms, pourquoi ne pas s'en servir ? Ce que tu ne dis pas, c'est la position de la broche AVANT le déplacement demandé, ET la distance demandée. Il y a plein de facteurs qui pourraient expliquer cela, mais il faut vraiment beaucoup plus de détails. Paramètres GRBL, entre autres.
Bien cordialement,
Bernard
Image
Image
Avatar du membre
samsab
Apprenti
Messages : 30
Enregistré le : 24 sept. 2021, 12:51
A remercié : 1 fois
A été remercié : 1 fois

Re: COMPORTEMENT JOG BIZARRE

Message non lu par samsab » 20 févr. 2022, 09:12

merci pour ta réponse
je vais tacher de les nommer correctement
Etant newbie, tout est un peu confus encore
la broche peut etre n'importe où avant cette séquence particulière (qui demande un déplacement de 100mm), que les axes aient été remis à 0 ou pas, toujours ce non mouvement pour cette commande croisée vers X+/Y+

je ne crois rien déceler dans le parametrage de grbl qui explique ce comportement
Grbl 1.1h ['$' for help]
>>> $$
$0 = 10 (Step pulse time, microseconds)
$1 = 255 (Step idle delay, milliseconds)
$2 = 0 (Step pulse invert, mask)
$3 = 3 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 0 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 1 (Status report options, mask)
$11 = 0.010 (Junction deviation, millimeters)
$12 = 0.002 (Arc tolerance, millimeters)
$13 = 0 (Report in inches, boolean)
$20 = 0 (Soft limits enable, boolean)
$21 = 0 (Hard limits enable, boolean)
$22 = 1 (Homing cycle enable, boolean)
$23 = 0 (Homing direction invert, mask)
$24 = 25.000 (Homing locate feed rate, mm/min)
$25 = 500.000 (Homing search seek rate, mm/min)
$26 = 250 (Homing switch debounce delay, milliseconds)
$27 = 1.000 (Homing switch pull-off distance, millimeters)
$30 = 1000 (Maximum spindle speed, RPM)
$31 = 0 (Minimum spindle speed, RPM)
$32 = 0 (Laser-mode enable, boolean)
$100 = 200.000 (X-axis travel resolution, step/mm)
$101 = 200.000 (Y-axis travel resolution, step/mm)
$102 = 400.000 (Z-axis travel resolution, step/mm)
$110 = 5000.000 (X-axis maximum rate, mm/min)
$111 = 5000.000 (Y-axis maximum rate, mm/min)
$112 = 1000.000 (Z-axis maximum rate, mm/min)
$120 = 200.000 (X-axis acceleration, mm/sec^2)
$121 = 200.000 (Y-axis acceleration, mm/sec^2)
$122 = 200.000 (Z-axis acceleration, mm/sec^2)
$130 = 200.000 (X-axis maximum travel, millimeters)
$131 = 200.000 (Y-axis maximum travel, millimeters)
$132 = 200.000 (Z-axis maximum travel, millimeters)
CNC TOPSCNC + NEMA 23 + ARDUINO GRBL 1.1 sans cncshield, pontage direct de y1 et y2, plutôt UGS en ce moment
Avatar du membre
DranerB
Administrateur
Messages : 3311
Enregistré le : 31 janv. 2019, 11:56
Localisation : Bourbon-Lancy, France
A remercié : 160 fois
A été remercié : 275 fois
Contact :

Re: COMPORTEMENT JOG BIZARRE

Message non lu par DranerB » 20 févr. 2022, 11:48

samsab a écrit : 20 févr. 2022, 09:12 merci pour ta réponse
je vais tacher de les nommer correctement
Etant newbie, tout est un peu confus encore
la broche peut etre n'importe où avant cette séquence particulière (qui demande un déplacement de 100mm), que les axes aient été remis à 0 ou pas, toujours ce non mouvement pour cette commande croisée vers X+/Y+

je ne crois rien déceler dans le parametrage de grbl qui explique ce comportement
Grbl 1.1h ['$' for help]
>>> $$
$0 = 10 (Step pulse time, microseconds)
$1 = 255 (Step idle delay, milliseconds)
$2 = 0 (Step pulse invert, mask)
$3 = 3 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 0 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 1 (Status report options, mask)
$11 = 0.010 (Junction deviation, millimeters)
$12 = 0.002 (Arc tolerance, millimeters)
$13 = 0 (Report in inches, boolean)
$20 = 0 (Soft limits enable, boolean)
$21 = 0 (Hard limits enable, boolean)
$22 = 1 (Homing cycle enable, boolean)
$23 = 0 (Homing direction invert, mask)
$24 = 25.000 (Homing locate feed rate, mm/min)
$25 = 500.000 (Homing search seek rate, mm/min)
$26 = 250 (Homing switch debounce delay, milliseconds)
$27 = 1.000 (Homing switch pull-off distance, millimeters)
$30 = 1000 (Maximum spindle speed, RPM)
$31 = 0 (Minimum spindle speed, RPM)
$32 = 0 (Laser-mode enable, boolean)
$100 = 200.000 (X-axis travel resolution, step/mm)
$101 = 200.000 (Y-axis travel resolution, step/mm)
$102 = 400.000 (Z-axis travel resolution, step/mm)
$110 = 5000.000 (X-axis maximum rate, mm/min)
$111 = 5000.000 (Y-axis maximum rate, mm/min)
$112 = 1000.000 (Z-axis maximum rate, mm/min)
$120 = 200.000 (X-axis acceleration, mm/sec^2)
$121 = 200.000 (Y-axis acceleration, mm/sec^2)
$122 = 200.000 (Z-axis acceleration, mm/sec^2)
$130 = 200.000 (X-axis maximum travel, millimeters)
$131 = 200.000 (Y-axis maximum travel, millimeters)
$132 = 200.000 (Z-axis maximum travel, millimeters)
J'ai un peu l'impression qu'on se focalise sur ce qui n'est pas réellement important. Tes paramètres GRBL montrent qu'il n'est PAS paramétré. Tu as $22=1, mais aucune des limites n'est active, et tes paramètres $131, $131 et $132 sont ceux par défaut de GRBL, je doute qu'ils correspondent à ta machine. Pareil pour $100, $101 et $102. Est-ce que tu as vérifié que si tu demandais un déplacement de 100mm, la machine faisait réellement 100mm ?

Je n'en suis pas certain, mais je pense que tu n'as pas besoin de résoudre ce problème spécifique de jogging, si tout le reste fonctionne par ailleurs. Par contre, pour pouvoir utiliser ta machine, tu as besoin de paramétrer GRBL correctement.
Bien cordialement,
Bernard
Image
Image
Avatar du membre
samsab
Apprenti
Messages : 30
Enregistré le : 24 sept. 2021, 12:51
A remercié : 1 fois
A été remercié : 1 fois

Re: COMPORTEMENT JOG BIZARRE

Message non lu par samsab » 20 févr. 2022, 11:52

les paramètres sont corrects en ce qui concerne les déplacements en x, y et z
10 mm demandés sont 10 mm obtenus
CNC TOPSCNC + NEMA 23 + ARDUINO GRBL 1.1 sans cncshield, pontage direct de y1 et y2, plutôt UGS en ce moment
Avatar du membre
DranerB
Administrateur
Messages : 3311
Enregistré le : 31 janv. 2019, 11:56
Localisation : Bourbon-Lancy, France
A remercié : 160 fois
A été remercié : 275 fois
Contact :

Re: COMPORTEMENT JOG BIZARRE

Message non lu par DranerB » 20 févr. 2022, 22:43

samsab a écrit : 20 févr. 2022, 11:52 les paramètres sont corrects en ce qui concerne les déplacements en x, y et z
10 mm demandés sont 10 mm obtenus
Tant mieux! Mais ils ne sont pas corrects pour le homing, ni pour les distances max.
Bien cordialement,
Bernard
Image
Image
Avatar du membre
samsab
Apprenti
Messages : 30
Enregistré le : 24 sept. 2021, 12:51
A remercié : 1 fois
A été remercié : 1 fois

Re: COMPORTEMENT JOG BIZARRE

Message non lu par samsab » 11 mars 2022, 10:13

j'ai trouvé!!!!!
j'ai honte......
figurez vous que j'avais oublié de connecter le fil de masse, à la masse.....
mes 3 drivers en x et y travaillaient alors sans masse reliée,
le jog manuel croisé (xy) refonctionne parfaitement.

avec le recul, je trouve bizarre malgré tout que les drivers répondaient presque bien, mais en tout cas mes ronds redeviennent enfin ronds et les points d'arrivée coïncident enfin avec le point de départ.
comme quoi, il faut toujours vérifier les choses basiques cad le cablage

merci à toi en tout cas
CNC TOPSCNC + NEMA 23 + ARDUINO GRBL 1.1 sans cncshield, pontage direct de y1 et y2, plutôt UGS en ce moment
Répondre