Page 1 sur 1

Python 2.7

Posté : 10 févr. 2020, 14:12
par alinb85
La version 2.7 n'est plus mis à jour depuis le 1er janvier 2020. Impossible mettre à jour la dernière version bCNC, erreur signalant l’obsolescence de python. Il y a certainement une solution mais je ne maîtrise pas. j'utilise actuellement la version 0.9.14 bêta (compilation windows).

Re: Python 2.7

Posté : 10 févr. 2020, 23:13
par DranerB
alinb85 a écrit :
10 févr. 2020, 14:12
La version 2.7 n'est plus mis à jour depuis le 1er janvier 2020. Impossible mettre à jour la dernière version bCNC, erreur signalant l’obsolescence de python. Il y a certainement une solution mais je ne maîtrise pas. j'utilise actuellement la version 0.9.14 bêta (compilation windows).
Tu mets la dernière version de python sur ta machine (3.8.1, à ma connaissance), en n'oubliant pas de cocher la case pour la mise à jour du Path, et l'installation complète avec les divers utilitaires.

Ensuite, tu fais tout bétement

Code : Tout sélectionner

pip install --upgrade bCNC
. Pour info, la dernière version est 0.9.14.303

S'il se trouvait que pip n'était pas installé, va sur cette page https://www.liquidweb.com/kb/install-pip-windows/ , installe sur ta machine, a priori dans le même répertoire que Python, le script get-pip.py, puis lance la commande

Code : Tout sélectionner

python get-pip.py

Re: Python 2.7

Posté : 25 mars 2020, 10:04
par alinb85
Je vous ai répondu via message, merci encore pour votre site que je ne consulte certainement pas suffisamment. Très cordialement.