FDC...en 2021

Discussion sur et autour de GRBL. Réglages, paramètres, différentes versions, questions, astuces, etc...
Pilou85
Compagnon
Messages : 132
Enregistré le : 21 avr. 2020, 09:03

FDC...en 2021

Message non lu par Pilou85 » 12 janv. 2021, 20:09

Bonsoir Bernard, me revoilà apres qques temps de pose ...trop de boulot à côté..........
Bon ce qui m'amène....les FDC....mince cela fait un moment que je ne me suis pas penché dessus et j'ai oublié certaines choses..pour resumer

j'etais en carte Allemande + arduino nano + FDC en NO avec $5=0 donc si je n'ai pas tout oublié c'est le reglage de base de Grbl.!

me voilà avec une Mega 2560 + Grbl 1.1e ( attention " e " et non " f " ) je suis en 4axes et tous les axes sont fonctionnels.....

MAIS lorsque je souhaite connecter mes FDC ( les 3 mêmes que sur ma CnC nano ) , les FDC ne repondent pas...toujours pour le NO avec $5=0....

je met les photos pour le cablage

je pensais avoir compris mais là, j'ai un " blanc "..... :D

Bonne soirée
Philippe
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Avatar du membre
DranerB
Administrateur
Messages : 2208
Enregistré le : 31 janv. 2019, 11:56
Localisation : Bourbon-Lancy, France
A remercié : 110 fois
A été remercié : 224 fois
Contact :

Re: FDC...en 2021

Message non lu par DranerB » 12 janv. 2021, 23:32

Pilou85 a écrit : 12 janv. 2021, 20:09 Bonsoir Bernard, me revoilà apres qques temps de pose ...trop de boulot à côté..........
Bon ce qui m'amène....les FDC....mince cela fait un moment que je ne me suis pas penché dessus et j'ai oublié certaines choses..pour resumer

j'etais en carte Allemande + arduino nano + FDC en NO avec $5=0 donc si je n'ai pas tout oublié c'est le reglage de base de Grbl.!

me voilà avec une Mega 2560 + Grbl 1.1e ( attention " e " et non " f " ) je suis en 4axes et tous les axes sont fonctionnels.....

MAIS lorsque je souhaite connecter mes FDC ( les 3 mêmes que sur ma CnC nano ) , les FDC ne repondent pas...toujours pour le NO avec $5=0....

je met les photos pour le cablage

je pensais avoir compris mais là, j'ai un " blanc "..... :D

Bonne soirée
Philippe
Si tu as 4 axes, sur un Mega 2560, on peut à priori en déduire que tu n'as pas le GRBL "standard" sur un Uno (Oui, je sais Sherlock ne ferait pas mieux!) :D
Ce que je veux dire par là, c'est que les pins et donc le câblage sont sans doute différents. Il faut se référer à la doc du GRBL modifié que tu utilises. Il y en a plusieurs, et je ne sais pas lequel tu as chargé.

Au cas où ce soit grl-Mega-5X, tu as des explications ici: https://github.com/fra589/grbl-Mega-5X/ ... -d'origine

Tu peux donc oublier le schéma de câblage joint.
Bien Cordialement,
Bernard
Image
Pilou85
Compagnon
Messages : 132
Enregistré le : 21 avr. 2020, 09:03

Re: FDC...en 2021

Message non lu par Pilou85 » 13 janv. 2021, 11:26

effectivement je n'avais pas pensé aux modifs de Grbl.... J'ai chargé le Grbl 1.1e

je vais regarder de plus prés ce soir....ceci etant le Grbl Mega X5 n'a qu'une seule connection d'interrupteur par axe...comme tu l'indiquais dans un de tes dossiers...

à +
Philippe
Pilou85
Compagnon
Messages : 132
Enregistré le : 21 avr. 2020, 09:03

Re: FDC...en 2021

Message non lu par Pilou85 » 22 janv. 2021, 15:11

Me revoilà...Salut Bernard....alors j'ai fait le point....j'ai bien Grbl 1.1.e ( attention c'est bien le " e " ) pour 4 axes qu'un collegue Canadien qu'il m'a envoyé...et NON MEGAX 5

donc il y a en plus les $103, 113, 123, 133 qui sont donc des valeurs à regler ou calculer comme les autres axes et cela fonctionne correctement sous CnCjs.....pas de pb à ce niveau...!

ensuite, j'ai pu , apres avoir grillée ma carte :evil: :o ...mais rien à voir avec les Fdc, tout simplement j'ai branché le 12v depuis mon alim principale et elle n'a pas aimé l'ampérage...OUUUU la belle fumée et piouuufff la belle flamme................bon, j'ai compris, voilà quand on essaye des choses avec peu de temps à y consacrer......;

bref, la nouvelle carte MEGA 2560 est en place et les 4 axes fonctionnent parfaitement avec en prime une alimentation DEDIEE en 9v par un transfo acheté avec la carte...! Cool, c'est mieux...!

Pour les Fdc.......le topo.....:: $20=0 soft limits desactivées, $21=1 hards limits activées , $22=1 lance le homing et toujours $23=3.....OK les moteurs s'arrêtent et on passe " ALARM "
ma connection pour cela....Pin 10 vers Haut de la RESISTANCE, bas de la resistance dans 5V, puis GND qui touche le haut de la resistance , le voltage donc descend et enclenche " Alarm "

L'avantage de CnCjs , je trouve, c'est de pouvoir deverouiller et passer outre Alarm pour tester un gcode chargé et les axes qui tournent même sans être sur la CnC

Dernier point, j'avais sur la carte Allemande + nano, les Fdc en NO avec les soft limit ACTIVES donc $20=1, $21=0

et là si je change sur la MEGA le setup pour être $20=1 ET $21=0 ET $22=1 ET $23=3.........AVEC LES MEMES CONNECTIONS, RIEN ne fait passer en alarm....??? et forcement les moteurs continuent

je prefererai être en Soft limit plutôt que Hard.........pour les raisons que tu evoques dans ton forum....

Serait-ce un " $ " du setup que je dois activé/désactivé ailleurs mais je ne vois pas trop.....

as tu un debut de piste que je puisse finaliser les connections et soudures...?

merci à toi , à bientôt
Philippe
Avatar du membre
DranerB
Administrateur
Messages : 2208
Enregistré le : 31 janv. 2019, 11:56
Localisation : Bourbon-Lancy, France
A remercié : 110 fois
A été remercié : 224 fois
Contact :

Re: FDC...en 2021

Message non lu par DranerB » 22 janv. 2021, 16:36

Pilou85 a écrit : 22 janv. 2021, 15:11 Me revoilà...Salut Bernard....alors j'ai fait le point....j'ai bien Grbl 1.1.e ( attention c'est bien le " e " ) pour 4 axes qu'un collegue Canadien qu'il m'a envoyé...et NON MEGAX 5

donc il y a en plus les $103, 113, 123, 133 qui sont donc des valeurs à regler ou calculer comme les autres axes et cela fonctionne correctement sous CnCjs.....pas de pb à ce niveau...!

ensuite, j'ai pu , apres avoir grillée ma carte :evil: :o ...mais rien à voir avec les Fdc, tout simplement j'ai branché le 12v depuis mon alim principale et elle n'a pas aimé l'ampérage...OUUUU la belle fumée et piouuufff la belle flamme................bon, j'ai compris, voilà quand on essaye des choses avec peu de temps à y consacrer......;

bref, la nouvelle carte MEGA 2560 est en place et les 4 axes fonctionnent parfaitement avec en prime une alimentation DEDIEE en 9v par un transfo acheté avec la carte...! Cool, c'est mieux...!

Pour les Fdc.......le topo.....:: $20=0 soft limits desactivées, $21=1 hards limits activées , $22=1 lance le homing et toujours $23=3.....OK les moteurs s'arrêtent et on passe " ALARM "
ma connection pour cela....Pin 10 vers Haut de la RESISTANCE, bas de la resistance dans 5V, puis GND qui touche le haut de la resistance , le voltage donc descend et enclenche " Alarm "

L'avantage de CnCjs , je trouve, c'est de pouvoir deverouiller et passer outre Alarm pour tester un gcode chargé et les axes qui tournent même sans être sur la CnC

Dernier point, j'avais sur la carte Allemande + nano, les Fdc en NO avec les soft limit ACTIVES donc $20=1, $21=0

et là si je change sur la MEGA le setup pour être $20=1 ET $21=0 ET $22=1 ET $23=3.........AVEC LES MEMES CONNECTIONS, RIEN ne fait passer en alarm....??? et forcement les moteurs continuent

je prefererai être en Soft limit plutôt que Hard.........pour les raisons que tu evoques dans ton forum....

Serait-ce un " $ " du setup que je dois activé/désactivé ailleurs mais je ne vois pas trop.....

as tu un debut de piste que je puisse finaliser les connections et soudures...?

merci à toi , à bientôt
Philippe

Bon, je ne suis pas sûr de tout comprendre. D'abord et avant tout, tu as bien vérifié que tes branchements homing/fins de course correspondent aux Pins de "ton" GRBL. Tu as une doc sur celui-ci ?

"Pin 10 vers Haut de la RESISTANCE, bas de la resistance dans 5V, puis GND qui touche le haut de la resistance , le voltage donc descend et enclenche " Alarm ""
Là je ne comprends vraiment pas ce dont tu veux parler. Quel est ce Pin 10 ?

et là si je change sur la MEGA le setup pour être $20=1 ET $21=0 ET $22=1 ET $23=3.........AVEC LES MEMES CONNECTIONS, RIEN ne fait passer en alarm....??? et forcement les moteurs continuent
Sans doc sur le GRBL que tu utilises, impossible de répondre. Va savoir ce qui a été changé !
Bien Cordialement,
Bernard
Image
Répondre